Browser VersionsΒΆ

Solano CI supports Chrome and Firefox out of the box. By default, the most recent version of both browsers are installed. Solano CI will use Firefox 24.0esr by default.

Historical versions of Firefox are also available, including at least the following versions:

8.0.1, 9.0.1, 10.0.5esr, 11.0, 12.0, 13.0, 14.0.1, 15.0, 16.0.2, 17.0, 18.0, 19.0, 20.0, 21.0, 23.0.1, 24.0esr, 25.0.1, 26.0, 27.0.1, 28.0, 29.0, 30.0, 31.0esr, 32.0, 32.0.2, 32.0.3, 33.0.3, 34.0.5, 35.0.1, 36.0.4, 37.0.2, 38.0esr, 39.0, 40.0, 41.0.2, 42.0, 43.0.4, 44.0.1, 45.0.1esr, 46.0.1, 47.0.2, 48.0.2, 49.0.2, 50.0.0, 52.0esr, 53.0.3, 54.0.1, and 55.0.0.

You can either use the default version or select a particular version via config/solano.yml. To select a particular version, add the following to your configuration:

firefox: '27.0.1'

If you need Selenium profile support for multiple browser versions, please contact support. If you are using Selenium Webdriver, be aware that the protocol between Selenium and the browser changes frequently so if you run into difficulty with your Selenium tests the first step should be to upgrade to the most recent version of Selenium.