CompatibilityΒΆ

Solano CI runs your tests in a 32- or 64-bit x86 Linux VM running Ubuntu 12.04. We have explicit support for a variety of languages, testing tools, and backend services. If you don’t see one you need listed here, please contact us at support@solanolabs.com: we may already have it up and running on Solano CI.

Languages:

Common testing tools include

  • Nosetests, rspec, cucumber, phpunit, etc.
  • PhantomJS 1.5.0, 1.6.1, 1.7.0, 1.8.{0,1}, 1.9.{1,6,7,8}, 2.0.0
  • CasperJS 1.0.0-RC6

We also natively support many databases and backend-services:

  • Sqlite 3
  • Postgres 8.4, 9.0, 9.1, 9.2, 9.3, 9.4, 9.5, and 9.6
  • Mysql 5.1, 5.5, 5.6, and 5.7
  • MongoDB 1.8.4, 2.0.7, 2.2.0, 2.4.2, 2.6.4, 3.2.8, and 3.3.11
  • Redis 2.2.15, 2.4.17, 2.6.16, 2.8.21, and 3.0.2
  • Memcached 1.4.7
  • Riak
  • Neo4J Community 1.9.6, 2.0.1
  • Solr full text search 1.4.x through 4.2.x
  • Elastic Search 0.17, 0.18, 0.19, 0.20, 0.90, 1.0 through 1.7, 2.0 through 2.4, and 5.0.1
  • Sphinx 0.9.9, 2.0, 2.1, and 2.2 full text search (ruby thinking_sphinx 1.4.5 or later)
  • Zookeeper 3.3.6 and 3.4.5
  • RabbitMQ
  • CouchDB
  • CouchBase 2.0, 2.1, and 2.2
  • Cassandra 1.0.12, 1.1.12, 1.2.16, and 2.0.7
  • NSQ 0.3.2